Vous êtes ici : Accueil / Debian GNU/Linux / Système / Logiciels / Configurer les dépôts Debian-Updates (ex volatile)

Configurer les dépôts Debian-Updates (ex volatile)

Par Pierre-Yves Landuré Dernière modification 29/11/2017 18:29

Les dépôts Debian-Updates proposent des versions plus récentes des logiciels proposés par Debian (par exemple, ClamAV). Cet article décrit une procédure automatisée d'activation de ces dépôts.

Ce guide est testé sur:

  • Debian 6.0 Squeeze
  • Debian 7.0 Wheezy

Mise en place des dépôts

Installez les prérequis d'installation:

command apt-get install lsb-release

Récupérez le nom de la distribution:

DEBIAN_VERSION="$(command lsb_release -cs)"

Détectez le miroir utilisé par l'installation actuelle:

MIRROR=$(command egrep "^deb.*${DEBIAN_VERSION}" '/etc/apt/sources.list' \
    | command egrep -v "updates|-src|cdrom" \
    | cut --delimiter=" " --fields=2)

Ajoutez les dépôts Debian-Updates à la configuration Apt:

command echo "# ${DEBIAN_VERSION}-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ ${DEBIAN_VERSION}-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ ${DEBIAN_VERSION}-updates main contrib non-free" \
    > "/etc/apt/sources.list.d/${DEBIAN_VERSION}-updates.list"

Mettez à jour la liste des paquets disponibles:

command apt-get update