Vous êtes ici : Accueil / Ubuntu GNU/Linux / Développement / Installer OCaml 4 et OPAM sur Ubuntu

Installer OCaml 4 et OPAM sur Ubuntu

Par Pierre-Yves Landuré Dernière modification 22/02/2014 17:49

Caml (prononcé camel, signifie Categorical Abstract Machine Language) est un langage de programmation généraliste conçu pour la sécurité et la fiabilité des programmes. Il se prête à des styles de programmation fonctionnelle, impérative et orientée objet. OCaml en est l'implémentation la plus avancée. OPAM est un gestionnaire de paquet pour OCaml. Ce guide facilite l'installation de OCaml 4 et OPAM sur Ubuntu.

Ce guide est testé sur:

  • Ubuntu 13.10 Saucy Salamander

Installation

Pour installer rapidement l'application, utilisez:

sudo bash -c 'command add-apt-repository ppa:avsm/ppa;
command apt-get update;
command apt-get -y install ocaml opam ocaml-compiler-libs ocaml-native-compilers'

Détails de l'installation

Ajoutez les dépôts PPA de l'application à la configuration apt:

sudo add-apt-repository ppa:avsm/ppa

Mettez à jour la liste des paquets disponibles:

sudo apt-get update

Installez la dernière version de l'application:

sudo apt-get install ocaml opam ocaml-compiler-libs ocaml-native-compilers

Vous disposez maintenant d'une version récente de OPAM et OCaml.

Remerciements